Задать вопрос
21 мая, 08:43

Организовать суммирование введённых с клавиатуры чисел до тех пор, пока значение суммы не превысит S. Вывести полученную сумму на экран.

+1
Ответы (1)
  1. 21 мая, 11:39
    0
    Var a, s, s1:Integer;

    begin

    Write ('Введите число, которое должна превысить сумма чисел (s) : ') ;

    ReadLn (s) ;

    while s1<=s do

    begin

    Write ('Введите число: ') ;

    ReadLn (a) ;

    s1:=s1+a

    end;

    WriteLn ('Сумма введенных чисел: ', s1)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Организовать суммирование введённых с клавиатуры чисел до тех пор, пока значение суммы не превысит S. Вывести полученную сумму на экран. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Прочитать с клавиатуры число n, затем прочитать n чисел и вывести на экран сумму тех из них, которые делятся на 3. 2. Прочитать с клавиатуры число n и вывести на экран сумму его четных цифр 3.
Ответы (1)
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)
Написать программу в Паскале, которая прибавляет к 1 число 7 до тех пор, пока полученная сумма не превысит max число, введенное с клавиатуры. После каждого действия вывести полученную сумму, если она меньше max числа
Ответы (1)
составьте программу которая а) выполняет операцию сцепления трех введенных с клавиатуры символов б) выполняет операцию сцепления трех введенных с клавиатуры символов и выводит результат сравнения на экран.
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)