Задать вопрос
26 января, 17:32

составить программу суммирования натуральных чисел 1 ... n пока их сумма не превысит величину h. Вывести на экран последнее слагаемое и сумму

+5
Ответы (2)
  1. 26 января, 17:37
    0
    Readln (n, h) ;

    for i:=1 to n do begin

    s:=s+i;

    if s>h then

    break;

    end;

    writeln (i, s) ;
  2. 26 января, 19:07
    0
    Uses crt;

    var n, h, i, sum:integer;

    begin

    read (n, h) ;

    while sum<=h do

    begin

    sum+=i;

    i+=1;

    end;

    writeln (i-1,' ', sum-i) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «составить программу суммирования натуральных чисел 1 ... n пока их сумма не превысит величину h. Вывести на экран последнее слагаемое и ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
Паскаль. 1. вывести на экран все четные числа от 1 до n. 2. вывести на экран все трехзначные числа. 3. вывести на экран четырехзначные числа оканчивающийся на 7. 4. вывести на экран все трехзначные и двухзначные числа сумма цифр которых равна девяти.
Ответы (1)
1. Прочитать с клавиатуры число n, затем прочитать n чисел и вывести на экран сумму тех из них, которые делятся на 3. 2. Прочитать с клавиатуры число n и вывести на экран сумму его четных цифр 3.
Ответы (1)
1. Пользователем вводится целое число. Вывести на экран последовательность целых чисел от единицы до этого числа. 2. Вывести на экран 10 строк, содержащие символ *, причем количество * в каждой строке должно быть равно номеру строки. 3.
Ответы (1)