Задать вопрос
26 ноября, 01:17

Дано четырехзначное число. Изменить его так чтобы количество десятков стало равно нулю (написать программу паскаль)

+2
Ответы (2)
  1. 26 ноября, 03:03
    0
    var a, b1, b2:integer;

    begin

    readln (a) ; / / считываем число

    b1:=a mod 10; / / единицы

    b2: = (a - b1) mod 100; / / десятки

    write (a-b2) ; / / число минус десятки

    end.
  2. 26 ноября, 03:44
    0
    var a:integer;

    begin

    a:=1234;

    a: = (a div 100) * 100 + a mod 10;

    Write ('a = ', a) / / тут выведет: a = 1204

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано четырехзначное число. Изменить его так чтобы количество десятков стало равно нулю (написать программу паскаль) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
47. дано целое четырехзначное положительное число n. составьте программу, которая определяет, какая из его цифр больше-вторая или последняя 48 дано целое четырехзначное положительное число n.
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
1) Дано целое число N. Написать программу, заменяющую его 1, если число меньше нуля, и увеличивающую его на 6, если число больше или равно нулю. 2) Даны два числа a и b. Написать программу, которая выводит номер большего из них
Ответы (1)