Задать вопрос
16 февраля, 07:39

Написать программу на алгоритмическом языке Паскаль. Вывести наименование и стоимость продукта, которого на складе меньше всего.

+5
Ответы (1)
  1. 16 февраля, 08:14
    0
    Const

    nm = 50; { предельное число товаров }

    var

    mn: array[1 ... nm] of string;

    mk, ms: array[1 ... nm] of real;

    i, k, n: integer;

    min: real;

    begin

    Write ('Введите число продуктов на складе (не более ', nm, ') : ') ;

    Readln (n) ;

    min : = 1e10;

    for i : = 1 to n do

    begin

    Write ('Наименование продукта ', i, ': ') ; Readln (mn[i]) ;

    Write ('Количество и стоимость: ') ; Readln (mk[i], ms[i]) ;

    if min > mk[i] then begin min : = mk[i]; k : = i end

    end;

    Writeln ('На складе меньше всего продукта ', mn[k], ': ', mk[k],

    ' кг. стоимостью ', ms[k], ' руб. за 1 кг.')

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу на алгоритмическом языке Паскаль. Вывести наименование и стоимость продукта, которого на складе меньше всего. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Ввести стоимость покупки в магазине, если стоимость меньше тысячи, то вывести "скидки нет", если стоимость от 1000 до 5000, то вывести "скидка 5%", если стоимость свыше 5000, то вывести "скидка 10%". Вывести сумму со скидкой.
Ответы (1)
Задача_1: Составить программу на языке Паскаль для вычисления выражения y:=sqr (x) + x/3+sqr (sin (x)) Задача_2: Составить программу на языке Паскаль для вычисления площади треугольника по трем сторонам (подсказка: это формула Герона) Задача_3:
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
Написать программу на языке Паскаль. 1. Написать программу из 3 введенных значений. Найти максимальное 2. Написать программу запрашивающую номер класса и выводящееся сообщения если 1-4 класса-младшая школа, 5-9-средняя, 10-11-старшая 3.
Ответы (1)