Задать вопрос
5 января, 09:24

С клавиатуры вводятся числа N и K. Вывести на экран / / наименьший делитель введённых чисел.

+1
Ответы (1)
  1. 5 января, 11:21
    0
    Pascal

    Program del;

    Var n, k, I, a, b, m : integer;

    Begin

    Readln (n, k) ;

    M = - 1;

    For i:=2 to n do

    Begin

    a:=n mod i;

    b:=k mod I;

    If (a=0) and (b=0) and (m = - 1) then

    M = I;

    end;

    If m = - 1 then

    Writeln ("NO")

    Else writeln (m) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «С клавиатуры вводятся числа N и K. Вывести на экран / / наименьший делитель введённых чисел. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дан массив из N элементов (12 элементов), заданный случайным образом от - 10 до 10. Вывести на экран этот массив. С клавиатуры вводятся два числа меньше N. Вывести на экран часть массива входящих в диапазон, двух введенных чисел.
Ответы (1)
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)
Паскаль. 1. вывести на экран все четные числа от 1 до n. 2. вывести на экран все трехзначные числа. 3. вывести на экран четырехзначные числа оканчивающийся на 7. 4. вывести на экран все трехзначные и двухзначные числа сумма цифр которых равна девяти.
Ответы (1)
составьте программу которая а) выполняет операцию сцепления трех введенных с клавиатуры символов б) выполняет операцию сцепления трех введенных с клавиатуры символов и выводит результат сравнения на экран.
Ответы (1)
Помогите решить задачи! 1. Дан массив размера 10, числовые значения которого вводятся с клавиатуры. Вывести максимальный элемент данного массива и его номер. 2. Дан массив размера 10, числовые значения которого вводятся с клавиатуры.
Ответы (1)