Задать вопрос
10 октября, 00:11

Дано четырехзначное число. Напишите программу, определения суммы первой и последней цифр этого числа

+3
Ответы (1)
  1. 10 октября, 02:46
    0
    Var

    a, a1, a4: integer;

    begin

    readln (a) ;

    a1 : = a div 1000;

    a4 : = a mod 10;

    writeln (a1 + a4) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано четырехзначное число. Напишите программу, определения суммы первой и последней цифр этого числа ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
47. дано целое четырехзначное положительное число n. составьте программу, которая определяет, какая из его цифр больше-вторая или последняя 48 дано целое четырехзначное положительное число n.
Ответы (1)
1. Дано двузначное число. Определить: a. какая из его цифр больше, первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число. Определить, равен ли квадрат этого числа учетверённой сумме кубов его цифр.
Ответы (1)
Дано целое положительное четырехзначное число. Напишите программу, позволяющую определить двузначное число, в котором число десятков соответствует первой цифре заданного числа, а число единиц-последней. Например: 3234 = > 34.
Ответы (1)
Напишите программу, которая сначала считывает целое положительное число, а затем печатает значение меньшей из его первой и последней цифр. Исходное число не превышает 30 000.
Ответы (1)