Задать вопрос
13 ноября, 03:15

На с + + с циклом white

На вход программы подается 10 чисел. Выведите в столбик для каждого из них число, равное удвоенному квадрату первоначального числа.

Формат входных данных

В единственной строке через пробел вводятся 10 целых чисел, по модулю не превосходящих 1000.

Формат выходных данных

Необходимо вывести 10 строк, в каждой из которых будет по одному числу - результат преобразования исходных чисел.

Примеры

входные данные выходные данные

1 10 2 4 2 5 3 6 101 11

2

200

8

32

8

50

18

72

20402

242

+2
Ответы (1)
  1. 13 ноября, 03:46
    0
    Решение с массивами

    #include

    using namespace std;

    int main () {

    int a[10];

    int i = 0;

    while (i < 10) {

    cin >> a[i];

    ++i;

    }

    i = 0;

    while (i < 10) {

    cout << (2 * a[i] * a[i]) << endl;

    ++i;

    }

    return 0;

    }

    Решение без массивов (онлайн-вывод)

    #include

    using namespace std;

    int main () {

    int x;

    int i = 0;

    while (i < 10) {

    cin >> x;

    cout << (2 * x * x) << endl;

    ++i;

    }

    return 0;

    }
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «На с + + с циклом white На вход программы подается 10 чисел. Выведите в столбик для каждого из них число, равное удвоенному квадрату ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить! 1))) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b, дающие остаток c при делении на d Входные данные 1 4 1 2 выходные данные 1 3 Входные данный 1 5 0 4 выходные данные 4 2))) Выведите все числа на отрезке от
Ответы (1)
Помогите решить задачу о Паскалю Дано четыре числа. Необходимо найти произведение тех чисел, которые находятся в диапазоне от 3 до 9 включительно. Формат входных данных С клавиатуры вводятся 4 целых числа, по модулю не превосходящих 20.
Ответы (1)
Задача D Три числа Дан массив из N целых чисел а1, а2, ..., an. Вам нужно проверить, есть ли в этом массиве три числа сумма которых равна нулю. Формат входных данных В первой строке входного файла содержится одно целое число N (1 ≤ N ≤ 2000).
Ответы (1)
С некоторого момента прошло N дней. Сколько полных недель прошло за этот период. Формат входных данных На вход программе подается 0≤N≤106. Формат выходных данных Вывести целое число - ответ на вопрос. Примеры: Вход 100 Выход 14
Ответы (1)
Дан массив a из n целых чисел. Требуется вывести только неотрицательные числа. Формат входных данных На первой строке входного файла записано натуральное число n (n≤100) - число элементов в массиве.
Ответы (1)