Задать вопрос
21 июня, 10:21

Задача D Три числа

Дан массив из N целых чисел а1, а2, ..., an. Вам нужно проверить, есть ли в этом массиве три числа сумма которых равна нулю.

Формат входных данных

В первой строке входного файла содержится одно целое число N (1 ≤ N ≤ 2000). Во второй строке находятся N целых чисел a1, a2, ..., aN (- 1000 ≤ ai ≤ 1000) - элементы массива.

Формат выходных данных

В единственной строке выходного файла выведите одно слово "YES", если в этом массиве есть три числа сумма которых равна нулю. Иначе, выведите "NO".

c + + надо решать!

+2
Ответы (1)
  1. 21 июня, 13:44
    0
    Program esep;

    var i, j, k, n, sum:integer;

    input, output:text;

    a:array[1 ... 100] of integer;

    flag:boolean;

    begin flag:=false;

    Assign (Input,'d. in') ;

    reset (input) ;

    readln (input, n) ;

    assign (output, 'd. out') ;

    rewrite (output) ;

    writeln ('Input elements') ;

    readln (n) ;

    for i:=1 to n do read (a[i]) ;

    for i:=1 to n do

    for j:=1 to n do

    for k:=1 to n do

    if (ij) and (jk) and (ik) then

    if a[i]+a[j]+a[k]=0

    then

    begin

    writeln (output,'Yes') ;

    flag:=true;

    halt;

    end;

    if flag=false then writeln (output,'No') ;

    close (input) ;

    close (output) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задача D Три числа Дан массив из N целых чисел а1, а2, ..., an. Вам нужно проверить, есть ли в этом массиве три числа сумма которых равна ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дан массив из N целых чисел a1, a2 ..., aN. Вам нужно проверить, есть ли в этом массиве три числа сумма которых равно нулю. Формат входных данных В певой строке входного файла содержится одно целое число n (1
Ответы (1)
Имя входного файла: стандартный ввод Имя выходного файла: стандартный вывод Ограничение по времени: 1 секунда Ограничение по памяти: 256 мегабайт У Жарасхана есть массив а из n чисел, к каждому числу массива Жарасхан должен применять лишь одну
Ответы (1)
Задача W. Сумма двух чисел Имя входного файла: sum. in Имя выходного файла: sum. out Ограничение по времени: 2 секунды Ограничение по памяти: 256 мегабайт Формат входного и выходного файла На первой строке входного файла находятся два целых числа a
Ответы (1)
H. Работа с несколькими массивами Дан массив a, состоящий из n целых чисел. Ваша задача - переписать его элементы в другой массив такого же размера следующим образом: сначала должны идти все отрицательные элементы, а затем все остальные.
Ответы (1)
Дан массив a из n целых чисел. Требуется сначала вывести все четные элементы, затем - нечетные. Формат входных данных На первой строке входного файла записано натуральное число n (n≤100) - число элементов в массиве.
Ответы (1)