Задать вопрос
17 мая, 15:37

Помогите решить задачу о Паскалю

Дано четыре числа. Необходимо найти произведение тех чисел, которые находятся в диапазоне от 3 до 9 включительно. Формат входных данных С клавиатуры вводятся 4 целых числа, по модулю не превосходящих 20. Формат выходных данных Необходимо вывести единственное число - искомое произведение. Если чисел, удовлетворяющих условию, нет, выведите - 1.

+5
Ответы (1)
  1. 17 мая, 19:32
    -2
    Var n, k, i: integer;

    begin k : = 1; for i : = 1 to 4 do begin read (n) ; if (n > = 3) and (n < = 9) then k : = k * n; end; if k = 1 then writeln (-1) else writeln (k) ; end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите решить задачу о Паскалю Дано четыре числа. Необходимо найти произведение тех чисел, которые находятся в диапазоне от 3 до 9 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Выведите все точные квадраты натуральных чисел, не превосходящие данного числа N. Формат входных данных Задано единственное число N. Формат выходных данных Необходимо вывести все точные квадраты натуральных чисел, не превосходящие данного числа N.
Ответы (1)
задается целое число N. нужно вывести количество четных делителей числа N. Формат входных данных Единственная строка входного файла содержит единственное целое число N (1
Ответы (1)
Дан массив из n элементов. Необходимо определить, есть ли в данном массиве элемент, равный заданному числу k ? Если есть, то вывести номер первого его вхождения. Формат входных данных С клавиатуры вводится натуральное число n (n≤100).
Ответы (1)
Дано натуральное трёхзначное число n. Найдите сумму и произведение цифр в нём. Формат входных данных Вводится целое число n (100≤n≤999) Формат выходных данных Требуется вывести сумму и произведение его цифр через пробел.
Ответы (1)
Формат входных данных: Дано целое число A и натуральное число i. Формат выходных данных: Обнулите у числа A его последние i бит и выведите результат обнуления. Помогите скорей, кто понимает, о чём идет речь!
Ответы (1)