Задать вопрос
23 декабря, 07:35

Формат входных данных:

Дано целое число A и натуральное число i.

Формат выходных данных:

Обнулите у числа A его последние i бит и выведите результат обнуления.

Помогите скорей, кто понимает, о чём идет речь!

+3
Ответы (1)
  1. 23 декабря, 10:33
    0
    Сдвигаем число А вправо на i бит, а потом сдвигаем результат влево на i бит. Освободившиеся правые разряды автоматически заполняются нулями.

    var

    a, i, j: integer;

    begin

    Write ('Введите через пробел целое А и натуральное i: ') ;

    Readln (a, i) ;

    a : = (a shr i) shl i;

    Writeln ('a=', a)

    end.

    Тестовое решение:

    Введите через пробел целое А и натуральное i: 124 5

    a=96
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Формат входных данных: Дано целое число A и натуральное число i. Формат выходных данных: Обнулите у числа A его последние i бит и выведите ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача C. Делители Дано целое число N. Вам нужно определить количество его делителей Формат входных данных Единственная строка входного файла содержит целое число N (1 < = N < = 10^12) Формат выходных данных Выведите ответ к задаче
Ответы (1)
задается целое число N. нужно вывести количество четных делителей числа N. Формат входных данных Единственная строка входного файла содержит единственное целое число N (1
Ответы (1)
Напишите рекурсивную функцию вычисления суммы цифр натурального числа. Формат входных данных На вход ваша программа получает одно натуральное число n (n
Ответы (1)
Дано натуральное трёхзначное число n. Найдите сумму и произведение цифр в нём. Формат входных данных Вводится целое число n (100≤n≤999) Формат выходных данных Требуется вывести сумму и произведение его цифр через пробел.
Ответы (1)
Напишите рекурсивную функцию подсчёта количества цифр в натуральном числе. Формат входных данных На вход ваша программа получает одно натуральное число n (1≤n≤216-11≤n≤216-1). Формат выходных данных Выведите одно число - количество цифр в числе n.
Ответы (2)