Задать вопрос
2 сентября, 18:11

Написать программу, находящую скорость или время или пройденное расстояние в зависимости от запроса пользователя. (авс паскаль)

+3
Ответы (1)
  1. 2 сентября, 18:32
    0
    Program fgg;

    var

    x: String[10];

    t, v, s: Real;

    begin

    Write ('Что будем искать?: ') ;

    ReadLn (x) ;

    if x = 'скорость' then

    begin

    Write ('Введите расстояние: ') ;

    ReadLn (s) ;

    Write ('Введите время: ') ;

    ReadLn (t) ;

    WriteLn ('Скорость=', s / t) ;

    end

    else if x = 'время' then

    begin

    Write ('Введите расстояние: ') ;

    ReadLn (s) ;

    Write ('Введите скорость: ') ;

    ReadLn (v) ;

    WriteLn ('Время=', s / v) ;

    end

    else if x = 'расстояние' then

    begin

    Write ('Введите скорость: ') ;

    ReadLn (v) ;

    Write ('Введите время: ') ;

    ReadLn (t) ;

    WriteLn ('Расстояние=', v * t) ;

    end

    else

    WriteLn ('Неверно указано, что будем искать.') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу, находящую скорость или время или пройденное расстояние в зависимости от запроса пользователя. (авс паскаль) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
1. составить программу и алгоритм находящую сумму цифр трехзначного числа 2. составить программу и алгоритм находящую все простые делители заданного числа
Ответы (1)
Какая персональная информация, размещенная на онлайн-ресурсе, должна быть удалена из поисковой системы по запросу пользователя? A. Любое групповое фото, на котором есть изображение данного пользователя. B.
Ответы (2)
Написать программу перевода из десятичной системы счисления в двоичную при помощи функций пользователя. Паскаль (Функции пользователя).
Ответы (1)
1) Разработайте программу, запрашивающую у пользователя длины обеих катетов прямоугольного треугольника, и выводящую на экран гипотезу по формуле Пифагора 2) Запросите у пользователя длину ребра куба, Найдите и выведите на экран площадь одной грани,
Ответы (1)