Задать вопрос
9 июля, 10:49

Дан массив a состоящий из n

целых чисел. Требуется найти количество пар соседних элементов массива, являющихся четными числами.

Формат входных данных

На первой строке записано целое число n (0

На второй строке через пробел записаны n

чисел (-1000≤ai≤1000)

- элементы массива.

Формат выходных данных

Требуется вывести единственное число - количество пар четных чисел.

+3
Ответы (1)
  1. 9 июля, 14:12
    0
    Var

    i, k, n: integer;

    a: array[1 ... 10000]of integer;

    begin

    k : = 0;

    readln (n) ;

    for i : = 1 to n do read (a[i]) ;

    for i : = 2 to n do if (a[i - 1] mod 2 = 0) and (a[i] mod 2 = 0) then k : = k + 1; write (k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив a состоящий из n целых чисел. Требуется найти количество пар соседних элементов массива, являющихся четными числами. Формат ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дан массив a из n целых чисел. Требуется сначала вывести элементы, стоящие на четных местах, затем - на нечетных. Формат входных данных На первой строке входного файла записано натуральное число n (n≤100) - число элементов в массиве.
Ответы (1)
Дан массив a из n целых чисел. Требуется вывести только элементы с четными значениями. Формат входных данных На первой строке входного файла записано натуральное число n (n≤100) - число элементов в массиве.
Ответы (1)
Дан массив a из n целых чисел. Требуется сначала вывести все четные элементы, затем - нечетные. Формат входных данных На первой строке входного файла записано натуральное число n (n≤100) - число элементов в массиве.
Ответы (1)
Дан массив целых чисел. Нумерация элементов начинается с 0. Выведите все элементы массива с четными номерами. Формат входных данных Сначала задано число N - количество элементов в массиве, N100. Далее через пробел записаны N чисел - элементы массива.
Ответы (1)
Дан массив a из n целых чисел. Требуется вывести только неотрицательные числа. Формат входных данных На первой строке входного файла записано натуральное число n (n≤100) - число элементов в массиве.
Ответы (1)