Задать вопрос
13 мая, 07:34

Написать программу перевода из десятичной системы счисления в двоичную при помощи функций пользователя. Паскаль (Функции пользователя).

+4
Ответы (1)
  1. 13 мая, 08:53
    0
    Program n1;

    var n: integer;

    function per (n: integer) : integer;

    var

    a: array[1 ... 500] of integer;

    i, c:integer;

    begin

    c: = 0;

    repeat

    c: = c + 1;

    a[c]: = n mod 2;

    n: = n div 2;

    until n = 0;

    for i: = c downto 1 do

    write (a[i]) ;

    end;

    begin

    write ('введите число: ') ;

    readln (n) ;

    per (n) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу перевода из десятичной системы счисления в двоичную при помощи функций пользователя. Паскаль (Функции пользователя). ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1.11010101,00011 переведите число из двоичной в десятичную систему счисления 2.10111101,110111 переведите число из двоичной в восьмиричную систему счисления 3.101100010100,1011 переведите число из двоичной в шестнадцатиричную систему счисления 4.
Ответы (1)
5. Системы счисления. a. Переведите данное число из десятичной системы счисления в двоичную, восьмеричную и шестнадцатеричную системы счисления: 114,22510 b. Переведите данные числа в десятичную систему счисления: 100111100,11012 1234,58 2B3, F416 c.
Ответы (1)
1) Десятичное число 4563 в двоичной системе счисления равно 2) Десятичное число 800 в восьмеричной системе счисления равно 3) Десятичное число 781 в шестнадцатеричной системе счисления равно 4) Двоичное число 1000000 в десятичной системе счисления
Ответы (1)
1. Перевести число 11011100 из двоичной в десятичную, восьмеричную и шестнадцатеричную системы счисления 2. Перевести число 471 из восьмеричной в десятичную, двоичную и шестнадцатеричную системы счисления 3.
Ответы (1)
7. Под основанием системы счисления понимают: a) количество используемых знаков в алфавите системы счисления; b) наибольшую цифру в алфавите системы счисления; c) название системы счисления;
Ответы (1)