Задать вопрос
26 апреля, 16:51

Составить программу

Дано число М (М<=12). Определить количество дней в данном месяце.

+5
Ответы (1)
  1. 26 апреля, 18:01
    0
    Ну ... а что сложного? Создаёшь структуру, заполняешь её, и обрабатываешь условие на входном M:

    #include

    #include

    #include

    int main (void) {

    setlocale (LC_ALL, "russian") ;

    struct months {

    char name[16];

    int days;

    };

    struct months m[12] = {

    {"Январь", 31},

    {"Февраль", 29},

    {"Март", 31},

    {"Апрель", 30},

    {"Май", 31},

    {"Июнь", 30},

    {"Июль", 31},

    {"Август", 31},

    {"Сентябрь", 30},

    {"Октябрь", 31},

    {"Ноябрь", 30},

    {"Декабрь", 31}

    };

    int M;

    printf ("Введите номер месяца: ") ;

    scanf ("%d", &M) ;

    if (M > 0 && M < 13) {

    M--;

    if (m[M]. days = = 29 || m[M]. days = = 30) {

    printf ("В месяце / "%s/" %d дней.", m[M]. name, m[M]. days) ;

    } else {

    printf ("В месяце / "%s/" %d день.", m[M]. name, m[M]. days) ;

    }

    } else {

    printf ("Неизвестный месяц.") ;

    }

    getch () ;

    return 0;

    }
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу Дано число М (М ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите информатика 8 класс Задача 1. Составить программу определяющую длину фамилии и имени. Задача 2. Даны два слова. Составить программу определяющую произведение данных слов. Задача 3.
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)
1. Составьте программу в Pascal ABC. Известно, что X кг конфет стоит A рублей. Определить, сколько стоит 1 кг и Y кг этих же конфет. 2. Составьте программу в Pascal ABC. Дано двузначное число. Найти сумму и произведение его цифр. 3.
Ответы (1)
Паскаль. 1) Дано трехзначное число, нужно найти число, полученное при прочтении его цифр справа налево. 2) Дано трехзначное число. В нем зачеркнули последнюю справа цифру и приписали ее в начале. Найти полученное число. 3) Дано трехзначное число.
Ответы (1)