Задать вопрос
15 марта, 12:34

Дан целочисленный массив C, длиною 15 элементов значениями диапазона [15; 45]. Найти сумму отрицательных и кратных по значению элементов. Гарантируется, что хотя бы один такой элемент есть.

+5
Ответы (1)
  1. 15 марта, 13:27
    0
    Обозначу елемент "кратных по значению" - E. Напишу програмку на Паскале:

    program sumOtrizatelnix;

    var A:array[1 ... 15] of integer;

    i, n, s, E:longint;

    begin

    readln (E) ;

    for i:=1 to 15 do

    read (A[i]) ; / / ввели с клавиатуры масив

    for i:=1 to 15 do

    if (A[i] mod E=0) or (A[i] < 0) then s:=s+A[i]; / / добавляем елемент если нам подходит

    writeln (s) ; / / выводим сумму

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан целочисленный массив C, длиною 15 элементов значениями диапазона [15; 45]. Найти сумму отрицательных и кратных по значению элементов. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Помогите написать программу! Дан целочисленный массив M из 15 элементов. Элементы массива могут принимать целые значения от - 500 до 500 и вводятся с клавиатуры. Найти и вывести: 1. Сумму квадратов отрицательных элементов.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
1.) Вывести на экран одномерный целочисленный массив, состоящий из 10 целых чисел из диапазона [-100; 100] 2.) Задан одномерный целочисленный массив, состоящий из 7 случайных чисел.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)