Задать вопрос
15 июня, 17:15

Найти наибольшее из трёх чисел (3 числа вводим с клавиатуры). Паскаль. Через while. С комментариями. Желательно попроще.

+4
Ответы (1)
  1. 15 июня, 17:37
    0
    var n, number, max:integer;

    begin

    n : = 3;

    while n > 0 do

    begin

    readln (number) ;

    if n = 3 then max : = number

    else if max < number then max : = number;

    n : = n - 1;

    end;

    writeln ('Максимальное число = ', max) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти наибольшее из трёх чисел (3 числа вводим с клавиатуры). Паскаль. Через while. С комментариями. Желательно попроще. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
Помогите: Практическая работа №3. Ветвления Уровень A. Напишите программу, которая получает с клавиатуры два целых числа и находит наибольшее и наименьшее из них. Пример: Введите два числа: 1 5 Наименьшее число 1 Наибольшее число 5 Уровень B.
Ответы (1)
Составить программу обмена значениями двух переменных, которые вводятся с клавиатуры. Образец: Вводим числа:a=3b=7 После обмена:b=3a=7 , через паскаль
Ответы (1)
Массив А вводится с клавиатуры. Найти среднее арифметическое его элементов с нечетными номерами. Размер вводим с клавиатуры (
Ответы (1)