Задать вопрос
25 декабря, 20:55

Массив А вводится с клавиатуры. Найти среднее арифметическое его элементов с нечетными номерами. Размер вводим с клавиатуры (<=20)

+4
Ответы (1)
  1. 25 декабря, 21:17
    0
    Program qwer;

    uses crt;

    var a : array [1 ... 50] of integer;

    sum, kol, i, raz: integer;

    Begin

    sum : = 0; kol : = 0;

    write ('Размер: ') ; readln (raz) ;

    for i : = 1 to raz do

    begin

    readln (a[i]) ;

    if i mod 2 = 1 then

    begin

    kol : = kol + 1; sum : = sum + a[i];

    end;

    end;

    write ('Cреднее арифметическое: ', sum / kol) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Массив А вводится с клавиатуры. Найти среднее арифметическое его элементов с нечетными номерами. Размер вводим с клавиатуры ( ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить через паскаль 1) массив А вводится с клавиатуры, найти среднее арифметическое его элементов с нечетными номерами, размер произвольный.
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1. Задайте массив из 10 элементов с помощью датчика случайных чисел. Найдите среднее арифметическое нечетных элементов массива с нечетными индексами. выведите на экран исходный массив и полученное среднее арифметическое. 2.
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)