Задать вопрос
25 декабря, 20:04

Алгоритм поиска максимального и минимального значений элементов двумерного массива, пример программы

+4
Ответы (1)
  1. 25 декабря, 20:58
    0
    Держи мой шаблон работы с матрицами, как раз пока только минимумы и максимумы

    const

    handsfree = true;

    var

    a: array[1 ... 100, 1 ... 100] of real;

    max, min: real;

    i, j, m, n: integer;

    begin

    {ввод матрицы}

    if handsfree then begin

    n : = random (20) + 2;

    m : = random (20) + 2;

    end

    else begin

    write ('n, m = ') ;

    readln (n, m) ;

    end;

    writeln ('Данные матрицы:') ;

    for i : = 1 to m do

    begin

    for j : = 1 to n do

    if handsfree then begin

    a[i, j] : = random (100) - 50;

    write (a[i, j]:4, ' ')

    end

    else

    read (a[i, j]) ;

    writeln;

    end;

    {минимумы и максимумы}

    max : = a[1, 1];

    min : = a[1, 1];

    for i : = 1 to m do

    for j : = 1 to n do

    begin

    if max < a[i, j] then max : = a[i, j];

    if min > a[i, j] then min : = a[i, j];

    end;

    writeln ('max = ', max) ;

    writeln ('min = ', min) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Алгоритм поиска максимального и минимального значений элементов двумерного массива, пример программы ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Visual basic 1. Сформировать одномерный массив из восьми вещественных значений. 2. Сформировать двумерный массив из А строк и В столбцов. 3. Составить программу для определения максимального и минимального элементов двумерного массива. 4.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
1. Дан массив 1 2 3 4 5 6 7 8 7 0 - 8 - 4 2 16 - 10 2 А Определите: А) размерность массива; Б) значение элемента А[3]; В) значение максимального элемента массива; Г) индекс первого отрицательного элемента массива;
Ответы (1)
Помогите составить программу в Paskal! 1) Вычислите значение минимального элемента массива 2) Вычислите сумму минисального и максимального элементов 3) Выведите номер минимального элемента 4) Выведите номера максимальных элементов и их количество
Ответы (1)