Задать вопрос
1 июня, 07:07

Накопить произведение введённых с клавиатуры чисел до тех пор пока значение произведения не превысят P. Вывести полученное произведение на экран.

+5
Ответы (1)
  1. 1 июня, 10:23
    0
    Var a, p, p1:Integer;

    begin Write ('Введите число, которое должно превысить произведение чисел (p) : ') ;

    ReadLn (p) ;

    p1:=1;

    while p1<=p do

    begin

    Write ('Введите число: ') ;

    ReadLn (a) ;

    p1:=p1*a

    end;

    WriteLn ('Произведение введенных чисел: ', p1)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Накопить произведение введённых с клавиатуры чисел до тех пор пока значение произведения не превысят P. Вывести полученное произведение на ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)
1. Прочитать с клавиатуры число n, затем прочитать n чисел и вывести на экран сумму тех из них, которые делятся на 3. 2. Прочитать с клавиатуры число n и вывести на экран сумму его четных цифр 3.
Ответы (1)
составьте программу которая а) выполняет операцию сцепления трех введенных с клавиатуры символов б) выполняет операцию сцепления трех введенных с клавиатуры символов и выводит результат сравнения на экран.
Ответы (1)
С клавиатуры вводится числа и находится их произведение до тех пор пока произведение чисел не привести 10 000. Посчитайте количество введенных чисел и полученное произведение.
Ответы (1)
Организовать суммирование введённых с клавиатуры чисел до тех пор, пока значение суммы не превысит S. Вывести полученную сумму на экран.
Ответы (1)