Задать вопрос
31 марта, 02:58

Решить 2 задачи в C++

1. Дано трёхзначное число. Вывести вначале его последнюю цифру (единицы), а затем - его среднюю цифру (десятки).

2. Дни недели пронумерованы следующим образом: 1 - понедельник, 2 - вторник, ...,6-суббота, 7 - воскресенье. Дано целое число К, лежащее в диапазоне 1-365. Определить номер дня недели для К-го дня года, если известно, что в этом году 1 января было вторником.

+2
Ответы (1)
  1. 31 марта, 03:44
    0
    1.

    #include

    int main ()

    {

    std::string str;

    std::cin >> str;

    std::cout << "Последняя цифра: " << str. back () << std::endl;

    std::cout << "Средняя цифра: " << str. at (str. length () / 2) << std::endl;

    return 0;

    }

    2.

    #include

    #include

    int main ()

    {

    const std::array name_of_days

    {

    "Понедельник",

    "Вторник",

    "Среда",

    "Четверг",

    "Пятница",

    "Суббота",

    "Воскресенье"

    };

    size_t number_of_day;

    std::cin >> number_of_day;

    std::cout << "День: " << name_of_days[ (number_of_day % 7) ] << std::endl;

    }
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Решить 2 задачи в C++ 1. Дано трёхзначное число. Вывести вначале его последнюю цифру (единицы), а затем - его среднюю цифру (десятки). 2. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
На Паскале помогите написать Дано целое число k (1
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Напишите программу в паскале. Дано: Дан порядковый номер дня года (отсчет идет с 1-го января). Требуется вывести номер дня недели этого дня, если 1 января - понедельник.
Ответы (1)
Дано целое число k. Определите, каким будет k-й день года: выходным (суббота и воскресенье) или будним (понедельник, вторник, среда, четверг, пятница), если 1 января - понедельник (На паскале)
Ответы (1)
1. Дано целое число, лежащее в диапазоне 1-999. Вывести его строку-описание вида "четное двузначное число","нечетное трехзначное число" и т. д. 2. Даны 3 переменные вещественного типа: А, В, С.
Ответы (1)