Задать вопрос
12 мая, 03:12

Дано целое число k. Определите, каким будет k-й день года: выходным (суббота и воскресенье) или будним (понедельник, вторник, среда, четверг, пятница), если 1 января - понедельник (На паскале)

+5
Ответы (1)
  1. 12 мая, 05:00
    0
    Program D;

    Var k, n: integer;

    Begin repeat write ('Введите номер дня: ') ;

    readln (k) ;

    until (1<=k) and (k<365) ;

    n:=k mod 7;

    Case n of

    1 ... 5: Writeln ('Рабочий день') ;

    6,0: Writeln ('Выходной день') ;

    end;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано целое число k. Определите, каким будет k-й день года: выходным (суббота и воскресенье) или будним (понедельник, вторник, среда, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
На Паскале помогите написать Дано целое число k (1
Ответы (1)
Написать программу в паскале по вычислению средний температуры за неделю. Исходные данные вводятся с клавиатуры: Понедельник 12 градусов Вторник 10 Среда 16 Четверг 18 Пятница 17 Суббота 16 Воскресенье 14
Ответы (1)
Дано целое число от 1 до 365, определить каким будет день года, (суббота, воскресенье, или будние) если 1 е января вторник. Java (NetBeans)
Ответы (1)
1. Допустим, сегодня четверг. Какой день недели будет через 100 дней? А) Суббота В) Пятница С) Четверг D) Воскресенье 2. В лесу живут 5 гномов. Известно, что старше Эльфа, Таурен младше Блада, Ворген старше Дренея и Блад младше Дренея.
Ответы (1)
Решить 2 задачи в C++ 1. Дано трёхзначное число. Вывести вначале его последнюю цифру (единицы), а затем - его среднюю цифру (десятки). 2. Дни недели пронумерованы следующим образом: 1 - понедельник, 2 - вторник, ...,6-суббота, 7 - воскресенье.
Ответы (1)