Задать вопрос
21 октября, 20:15

Написать программу в паскале по вычислению средний температуры за неделю. Исходные данные вводятся с клавиатуры: Понедельник 12 градусов Вторник 10 Среда 16 Четверг 18 Пятница 17 Суббота 16 Воскресенье 14

+4
Ответы (1)
  1. 21 октября, 23:11
    0
    var

    t: array [1 ... 7] of real; / / Массив температуры за неделю

    s: real;

    i: integer;

    begin

    s: = 0;

    for i: = 1 to 7 do / / Вводим температуру за каждый день

    begin

    writeln ('Введите температура в ', i, ' день недели') ;

    readln (t[i]) ;

    s: = s + t[i];

    end;

    writeln ('Средняя температуры за неделю: ', s / 7 : 0 : 5) ; {Выводим среднюю температуру за неделю с округлением до 5 знаков после запятой}

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу в паскале по вычислению средний температуры за неделю. Исходные данные вводятся с клавиатуры: Понедельник 12 градусов ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы