Задать вопрос
31 марта, 21:19

Напишите программу, которая соединяет четыре введенных слова в однy строку и выводит их три раза, причём в первой строке ставится в конце?, во второй?, а в третьей?

Pascal.

+2
Ответы (1)
  1. 1 апреля, 00:55
    0
    Program p1;

    uses crt;

    var s, s2, s3:string;

    i, a:integer;

    begin

    read (s) ;

    for i:=1 to 4 do begin

    a:=Pos (' ', s) ;

    s2:=Copy (s, 1, a-1) ;

    delete (s, 1, a) ;

    s3:=s3+s2;

    end;

    s3:=s3+s;

    for i:=1 to 3 do begin

    s3:=s3+'?';

    writeln (s3) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая соединяет четыре введенных слова в однy строку и выводит их три раза, причём в первой строке ставится в конце?, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
составьте программу которая а) выполняет операцию сцепления трех введенных с клавиатуры символов б) выполняет операцию сцепления трех введенных с клавиатуры символов и выводит результат сравнения на экран.
Ответы (1)
1) Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру. 2) Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
Помогите решить две задичи Задача: Написать программу, которая а) все буквы 'а' в строке st заменяет на букву 'о' и выводит новую строку на экран б) удаляет все буквы 'а' из строки и выводит новую строку на экран
Ответы (1)
1. Напиши программу, которая присваивает переменной х значение 9, а затем выводит на экран: в первой строке это значение с поясняющей надписью (например значение х равно 9), а во второй - квадрат этого значения (тоже - с поясняющей надписью). 2.
Ответы (1)