Задать вопрос
5 января, 11:36

Отрезок на плоскости задается двумя несовпадающие конечными точками A (x1; y1) и B (x2; y2). Из точки С (х3; у3) к прямой, содержащей отрезок АВ, проводится перпендикуляр. Определить, попадает перпендикуляр на отрезок АВ или на его продолжение. Во входном файле содержится три пары чисел, являющихся координатами точек А, В, С. В файле содержится ответ "На отрезок" или "На продолжение".

+2
Ответы (1)
  1. 5 января, 11:42
    0
    program z3;

    var x1, x2, x3, y1, y2, y3, ac, ab, bc, a1, b1:real; f, f1:text;

    begin

    assign (f, 'z1. dat') ;

    rewrite (f) ;

    readln (x1, y1) ;

    readln (x2, y2) ;

    readln (x3, y3) ;

    writeln (f, x1, y1) ;

    writeln (f, x2, y2) ;

    writeln (f, x3, y3) ;

    close (f) ;

    ac:=sqr (x1-x3) + sqr (y1-y3) ;

    ab:=sqr (x2-x1) + sqr (y2-y1) ;

    bc:=sqr (x3-x2) + sqr (y3-y2) ;

    b1: = (ab+bc-ac) / (2*sqrt (ab*bc)) ;

    a1: = (ac+ab-bc) / (2*sqrt (ac*ab)) ;

    if (a1 < 0) or (b1 < 0) then

    begin

    assign (f1, 'z1. rez') ;

    rewrite (f1) ;

    writeln ('na prodolzenue') ;

    writeln (f1,'na prodolzenue') ; close (f1)

    end

    else

    begin

    assign (f1, 'z1. rez') ;

    rewrite (f1) ;

    writeln ('na otrezke') ;

    writeln (f1,'na otrezke') ;

    close (f1)

    end

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Отрезок на плоскости задается двумя несовпадающие конечными точками A (x1; y1) и B (x2; y2). Из точки С (х3; у3) к прямой, содержащей ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Два игрока играют в игру. На координатной плоскости стоит фишка. Игроки ходят поочереди. В начале игры фишка находится в точке с координатами (4,2).
Ответы (1)
Заданное число M из диапазона 0 ... 109. перевести в троичную систему счисления. Число M хранится в входном файле Exch. in, его представление в троичной системе счисления сохранить в выходном файле Exch. out.
Ответы (1)
Дан символьный файл f. Записать в файле g, с сохранением порядка их следования, те символьные данные: a) которым в файле f предшествует буква а б) в след за которыми в файле f идёт буква а
Ответы (1)
Задача для паскаля. Во входном файле имеется массив из 10 целых чисел. Первые 9 элементов упорядочены. В выходной файл вставить 10-й элемент так, чтобы все элементы массива были упорядочены.
Ответы (1)
Во входном файле расположена последовательность из 10-ти целых чисел. Вывести те из них, которые встречаются в последовательности один раз. только на TurboPascal!
Ответы (1)