Задать вопрос
30 июня, 19:34

Во входном файле расположена последовательность из 10-ти целых чисел. Вывести те из них, которые встречаются в последовательности один раз. только на TurboPascal!

+2
Ответы (1)
  1. 30 июня, 23:13
    0
    Uses Crt;

    Const

    N = 10;

    Var

    f:text;

    S:string;

    A:array[1 ... N] of longint;

    i, j, k:integer;

    Begin

    ClrScr;

    WriteLn ('Введите имя файла текстового, если он лежит в папке с программой (ВходнойФайл. txt) ') ;

    WriteLn ('Или введите полное имя файла (C: / ... / ВходнойФайл. txt) ') ;

    ReadLn (S) ;

    Assign (f, S) ;

    Reset (f) ;

    i:=1;

    Repeat

    Read (f, A[i]) ;

    i:=i+1;

    Until i>N;

    Write ('Содержимое файла:') ;

    For i: = 1 to N do

    Write (' ', A[i]) ;

    WriteLn;

    Write ('Уникальные элементы:') ;

    For i: = 1 to N do

    Begin

    k:=1;

    For j: = 1 to N do

    if ij then

    if A[i]=A[j] then k:=k+1;

    if k=1 then Write (' ', A[i])

    End;

    ReadLn;

    End.

    Пример:

    Введите имя файла текстового, если он лежит в папке с программой (ВходнойФайл. txt)

    Или введите полное имя файла (C: / ... / ВходнойФайл. txt)

    123. txt

    Содержимое файла: 1 2 13 5 2 1 3 17 19 21

    Уникальные элементы: 13 5 3 17 19 21
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Во входном файле расположена последовательность из 10-ти целых чисел. Вывести те из них, которые встречаются в последовательности один раз. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дана строка S, состоящая из слов, разделённых пробелами. Выведите все слова, которые встречаются в S ровно один раз. Формат входных данных Во входном файле дана строка S.
Ответы (1)
Дана строка, состоящая из слов, разделённых пробелами. Выведите все слова, которые встречаются в ровно один раз. Формат входных данных Во входном файле дана строка.
Ответы (1)
Заданное число M из диапазона 0 ... 109. перевести в троичную систему счисления. Число M хранится в входном файле Exch. in, его представление в троичной системе счисления сохранить в выходном файле Exch. out.
Ответы (1)
Вывести все значения элементов заданной числовой последовательности. Входные данные: Выходные данные: Во входном потоке в первой строке записано единственное целое число N (0 < N < = 100) - число элементов числовой последовательности;
Ответы (1)
Составить программу: 1. Дана последовательность чисел. Найти количество отрицательных элементов. Последовательность целых чисел Найти сумму между максимальными и минимальным элементом последовательность 0-признак конца ведения последовательности. 2.
Ответы (1)