Задать вопрос
4 июня, 04:20

Помогите!

Напишите на любом известном вам языке программирования программу, которая находит минимальное значение в массиве из N (N < = 100) натуральных чисел. Программа должна считывать сначала количество элементов массива, а затем сам массив и выводить одно число - минимальный элемент массива.

+1
Ответы (2)
  1. 4 июня, 05:11
    0
    Так как изначально в задании указано : "на любом известном вам языке программирования" - вот, держи на С.

    #include

    #include

    #include

    #define N 100

    int main ()

    {

    setlocale (LC_ALL, "Rus") ;

    int i, M;

    float B[N], MIN;

    printf (" Введите количество элементов массива (не больше 100) = > ") ;

    scanf ("%d", &M) ;

    if (M < 100)

    {

    for (i = 0; i < M; i++)

    {

    printf ("Введите [%d] элемент массива = >", i) ;

    scanf ("%f", &B[i]) ;

    }

    for (i = 0; i < M; i++)

    printf ("%1.0f ", B[i]) ;

    MIN=B[0];

    for (int i=1; i
    {

    if (B[i]
    MIN=B[i];

    }

    printf ("/n/tМинимальное значение в массиве = > %7.2f", MIN) ;

    }

    else

    printf ("Ошибка. Заданное число элементов массива слишком большое.") ;

    return 0;

    }
  2. 4 июня, 07:52
    0
    Program Minimum;

    Var i, n, Min : integer;

    a : array [1 ... 100] of integer;

    Begin

    Writeln ('Введите количество элементов массива') ;

    Readln (n) ;

    For i : = 1 to n do

    begin

    read (a[i]) ;

    end;

    Min : = a[1];

    for i : = 2 to n do

    if a[i]
    writeln ('Минимальный элемент массива = ', Min) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите! Напишите на любом известном вам языке программирования программу, которая находит минимальное значение в массиве из N (N < = 100) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу, которая фармирует масси из N элементов (максимальное количество элементов равно 20), значения элементов массива - случайные числа от - 10 до 25 Программа должна: 1) выводить на экран сначала все элементы массива, стоящие на
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
Составьте программу, которая вводит с клавиатуры 8 целых неотрицательных чисел (каждое число - с новой строки отдельной командой "ввод"), записывает их в массив, выводит на экран сначала в прямом порядке все без исключения элементы массива, затем, в
Ответы (1)