Задать вопрос
9 мая, 14:45

Составьте программу, которая вводит с клавиатуры 8 целых

неотрицательных чисел (каждое число - с новой строки отдельной

командой "ввод"), записывает их в массив, выводит на экран сначала в

прямом порядке все без исключения элементы массива, затем, в обратном

порядке относительно следования в массиве, все чётные элементы.

Например, для массива "1 2 5 4 5 3 7 8" программа должна выводить

числа в таком порядке: 1 2 5 4 5 3 7 8 8 4 2.

Каждое число программа должна выводить в отдельной строке; ничего,

кроме чисел, программа выводить не должна.

+1
Ответы (1)
  1. 9 мая, 17:25
    0
    var

    A:array [1 ... 8] of byte;

    i:integer;

    begin

    for i:=1 to 8 do readln (A[i]) ;

    for i:=1 to 8 do writeln (A[i]) ;

    for i:=8 downto 1 do

    begin

    if not Odd (A[i]) then writeln (A[i]) ;

    end;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу, которая вводит с клавиатуры 8 целых неотрицательных чисел (каждое число - с новой строки отдельной командой "ввод"), ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу которая вводит с клавиатуры четыре целых числа a, b, c, d (каждое число - отдельной командой "ввод") и выводит на экране минимальное среди них. Ничего кроме этого программа выводить не должна.
Ответы (2)
Составить программу, которая вводит с клавиатуры четыре целых числа a, b, c (каждое число - с новой строки) и выводит на экран минимальное среди них. Ничего, кроме этого числа, программа выводить не должна. программу на паскаль
Ответы (2)
Кто поможет с решением, буду очень благодарна. Составьте программу, которая вводит с клавиатуры три целых числа: a, b, c (каждое число - с новой строки) и выводит на экран минимальное из них. Ничего, кроме этого числа программа выводить не должна.
Ответы (1)
10. Составьте программу, которая вводит с клавиатуры три целых числа: a, b, c (каждое число с новой строки) и выводит на экран максимальное из них. Ничего кроме этого числа, программа выводить не должна.
Ответы (1)
1. Разработать схему алгоритма, который вводит массив из Nцелых чисел и выводит на экран этот же массив в прямом и обратном порядке. Протестировать алгоритм на произвольных массивах, состоящих из 1 числа, из 5 чисел, из 10 чисел. 2.
Ответы (2)