Задать вопрос
4 мая, 23:17

Дан двумерный массив. Каждому элементу массива сменить знак на противоположный.

+3
Ответы (1)
  1. 5 мая, 01:36
    0
    Const nx = 20; var x: array[1 ... nx, 1 ... nx] of real; i, j, k, n, r, t: integer; begin Writeln ('Введите размер матрицы n') ; Read (n) ; Randomize; Writeln ('Исходный массив') ; for i : = 1 to n do begin for j : = 1 to n do begin x[i, j] : = Random (25) - 10; Write (x[i, j]:4) ; end; Writeln; end; Writeln; Writeln ('Измененный массив') ; for i : = 1 to n do begin for j : = 1 to n do begin x[i, j]: = x[i, j] * (-1) ; Write (x[i, j]:4) ; end; Writeln; end; end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан двумерный массив. Каждому элементу массива сменить знак на противоположный. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1. Дан двумерный массив размером 3x5. Вычислить сумму элементов массива 2. Дан массив целых чисел размеров 4 х4. Заменить все элементы главной диагонали на нули. Вывести на экран монитора содержимое массива до обработки и после обработки 3.
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)