Задать вопрос
26 июня, 21:22

В зависимости от введенного числа 1,2,3 программа должна вычислять длину окружности; площадь круга; объём цилиндра.

C=2πR

S=πR2

V=πR2H

+4
Ответы (2)
  1. 27 июня, 00:00
    0
    var k, r, h:integer;

    begin

    writeln ('1 - длина окружности; 2 - площадь круга; 3 - объём цилиндра') ;

    write ('k = ') ;

    readln (k) ;

    case k of

    1,2: begin write ('R = ') ; readln (r) ; end;

    3: begin write ('R, h: ') ; readln (r, h) ; end;

    end;

    case k of

    1: writeln ('C = ',2*pi*r:5:3) ;

    2: writeln ('S = ', pi*r*r:5:3) ;

    3: writeln ('V = ', pi*r*r*h) ;

    else writeln ('Ошибка ввода') ;

    end;

    end.

    Пример:

    1 - длина окружности; 2 - площадь круга; 3 - объём цилиндра

    k = 2

    R = 5

    S = 78.540
  2. 27 июня, 00:38
    0
    Язык C++. #include

    #include

    using namespace std;

    int main () {

    float c, s, v, h, r;

    int m;

    cout << "Выберите цифру, где: 1 - длина окружности, 2 - площадь круга, 3 - объем цилиндра." << endl;

    cin >> m;

    switch (m) {

    case (1) : {

    cout << "Введите радиус: " << endl;

    cin >> r;

    cout << "Длина окружности равна: " << 2*M_PI*r << endl;

    break;

    }

    case (2) : {

    cout << "Введите радиус: " << endl;

    cin >> r;

    cout << "Площадь круга равна: " << M_PI * pow (r, 2) << endl;

    break;

    }

    case (3) : {

    cout << "Введите радиус и высоту: " << endl;

    cin >> r >> h;

    cout << "Объем цилиндра равен: " << M_PI * pow (r, 2) * h << endl;

    break;

    }

    default:

    cout << "Некорректный ввод." << endl;

    }

    return 0;

    }
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В зависимости от введенного числа 1,2,3 программа должна вычислять длину окружности; площадь круга; объём цилиндра. C=2πR S=πR2 V=πR2H ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В зависимости от введённого символа L, S, V программа должна вычислять длину окружности; площадь круга; объём цилиндра. Составить программу на паскале.
Ответы (1)
Всё надо сделать на паскале. a) x^5 b) x^6 c) x^8 d) x^9 e) x^10 2 задание: Дан диаметр окружности d. Найти его длину (L=П*d) 3 задание: Найти длину окружности L и площадь круга S заданного радиуса R: L=2πR, S = πR^2 4 задание: Даны 2 числа a и b.
Ответы (1)
Дано три числа. Упорядочите их в порядке неубывания. Программа должна считывать три числа a, b, c, затем программа должна менять их значения так, чтобы стали выполнены условия a < = b < = c, затем программа выводит тройку a, b, c.
Ответы (1)
Вычислить Y в зависимости от x, введенного с клавиатуры Y = (х2, если х>0 х+1, если х
Ответы (1)
В Python С клавиатуры вводится натуральное число. Программа должна вывести следующее за ним четное число. Например, если ввести 7, то программа должна вывести 8, а если ввести 8, то программа должна вывести 10.
Ответы (1)