Задать вопрос
26 мая, 15:02

Задача на Паскаль: в одномерном массиве А (10) определить сумму и количество элементов, которые меньше 5.

+4
Ответы (1)
  1. 26 мая, 18:57
    0
    Const

    n=10;

    var

    a:array[1 ... n] of integer;

    i, s, k:integer;

    begin

    Randomize;

    Writeln ('Исходный массив') ;

    s:=0; k:=0;

    for i:=1 to n do begin

    a[i]:=Random (31) - 10;

    Write (a[i]:4) ;

    if a[i]<5 then begin Inc (k) ; s:=s+a[i] end

    end;

    Writeln;

    Writeln ('Элементов, меньших 5: ', k,', их сумма равна ', s)

    end.

    Пример

    Исходный массив

    18 18 9 - 7 2 - 10 9 16 11 - 7

    Элементов, меньших 5: 4, их сумма равна - 22
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задача на Паскаль: в одномерном массиве А (10) определить сумму и количество элементов, которые меньше 5. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. В одномерном массиве подсчитать сумму тех элементов массива, которые кратны 5, но не делятся на 3. 2. В одномерном массиве подсчитать произведение тех элементов массива, которые стоя на индексах, кратных 3, а сами элементы четные.
Ответы (2)
Задачи на массивы (в паскале) : 1. Найти количество нулей в одномерном массиве. 2. найти сумму элементов кратных 5. 3. найти сумму первых 5 элементов. 4. верно ли что в массиве есть два нуля. 5. найти сумму элементов из промежутка от А до В.
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
Паскаль 1) В одномерном массиве A (10) найти среди отрицательный элементов максимальный. 2) Дан массив из N элементов. Определить количество элементов, которые являются четными числами.
Ответы (1)
В одномерном массиве М, состоящем из 10 целых чисел, найти: а) количество нулевых элементов: б) сумму элементов, больших - 4: В) полу сумму элементов с четными индексами: г) произведение нечетных элементов
Ответы (1)