Задать вопрос
26 февраля, 07:09

Введите три стороны треугольника. Определите вид (равнобедренный, разносторонний, равносторонний)

+1
Ответы (1)
  1. 26 февраля, 10:51
    0
    Var a, b, c : integer;

    begin

    readln (a, b, c) ;

    if (not (a=b)) and (not (b=c)) and (not (a=c)) then writeln ('разносторонний')

    else if ((a=b) and (not (b=c)) and (not (a=c))) or ((b=c) and (not (b=a)) and (not (c=a))) or ((a=c) and (not (a=b)) and (not (c=b))) then writeln ('равнобедренный')

    else writeln ('равносторонний') ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Введите три стороны треугольника. Определите вид (равнобедренный, разносторонний, равносторонний) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Даны 3 стороны треугольника АВС-напечатать какой имеет вид треугольник. Проверьте где у меня ошибки: var a, b, c:integer; begin write ('введите a=') ; readln (a) write ('введите b=') ; readln (b) write ('введите c=') ;
Ответы (1)
Даны три положительных числа. Если они могут быть длинами сторон остроугольного треугольника, то вычислить его площадь и определить вид треугольника (равносторонний, равнобедренный или разносторонний), иначе выдать соответсвующее сообщение.
Ответы (1)
Составить программу на языке кумир по трем введенным сторонам надо сказать возможно ли существование такого треугольника и если да, то какой он: разносторонний, равносторонний или равнобедренный
Ответы (1)
Даны 3 стороны треугольника, составить программу в которой нужно определить равносторонний ли треугольник, если равносторонний, то вывести на экран сообщение треугольник - равносторонний
Ответы (1)
Составить программу, классифицирующую треугольники по сторонам, если заданы градусные меры трех углов (равносторонний, равнобедренный, разносторонний, прямоугольный).
Ответы (1)