Задать вопрос
15 октября, 19:41

написать программу для pascal: выиснить является ли заданное число совершенным?

+3
Ответы (2)
  1. 15 октября, 21:03
    0
    Program Pr1;

    uses crt;

    var i, n, a:integer;

    Begin

    clrscr;

    readln (n) ;

    i:=1; a:=0;

    while i<=n do begin

    if (n mod i=0) and (in) then a:=a+i;

    inc (i) ;

    end;

    if a=n then writeln ('YES')

    else writeln ('No') ;

    end.
  2. 15 октября, 23:15
    0
    uses

    SysUtils;

    var

    n, m, i:integer;

    begin

    readln (n) ;

    m:=0;

    for i : = 1 to n-1 do

    if m > n then break else

    if (n mod i = 0) then m:=m+i;

    if m=n then writeln ('Yes') else

    writeln ('No') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «написать программу для pascal: выиснить является ли заданное число совершенным? ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Натуральное число M называется совершенным, если оно равно сумме всех своих делителей, включая единицу, но исключая себя, является ли число м совершенным? Напиши программу в паскале циклов while или repeat
Ответы (1)
На языке паскаль абс написать программу (Не глушилку, а нормальную программу) (желательно с помощью Циклов и If-ов) Натуральное число называется совершенным, если оно равно сумме своих делителей, включая 1 и, естественно, исключая само число.
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)