Задать вопрос
1 июня, 05:34

Написать программу на С

Программа, которая переводит заданое число из восьмиричной системы в пятиричную

+2
Ответы (1)
  1. 1 июня, 06:54
    0
    Замечание: контроль правильности ввода не выполняется.

    #include

    int main (void) {

    int a_8, a_10, a_5, b, c;

    printf ("Введите число в восьмеричной системе счисления: ") ;

    scanf ("%d",&a_8) ;

    b = a_8;

    a_10 = 0; c = 1;

    while (b>0) {

    a_10 + = c * (b % 10) ;

    c * = 8;

    b / = 10;

    }

    b = a_10;

    a_5 = 0; c = 1;

    while (b>0) {

    a_5 + = c * (b % 5) ;

    c * = 10;

    b / = 5;

    }

    printf ("%d (8) = %d (10) = %d (5) ", a_8, a_10, a_5) ;

    return 0;

    }

    Пример:

    Введите число в восьмеричной системе счисления: 2014

    2014 (8) = 1036 (10) = 13121 (5)
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу на С Программа, которая переводит заданое число из восьмиричной системы в пятиричную ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, есть ли в последовательности нечетные числа не оканчивающихся на 1. Вход: программа получает на выход кол-во чисел, а затем сами числа.
Ответы (2)
Помогите сделать программу в Паскале В котором 1) Программа выдает сообщение "Вы маль или дево" 2) Пользователь в переменную ST1 задает значение маль или дево 3) Программа выдает сооб "Ты пошла бы играть в куклы" 4) Вводить ответ через переменную
Ответы (1)
Что относят к утилитам? Экономическая информатика антивирусная программа программа архивации данных программа диагностики дисков операционная оболочка программа обслуживания сети операционная система
Ответы (1)
Расположите запросы в порядке возрастания количества страниц. а) учитель / журнал/программа б) (учитель/журнал) & программа в) учитель& программа г) учитель&журнал&программа
Ответы (1)