Задать вопрос
29 марта, 22:35

Удаление повторяющихся чисел в массиве - Pascal ABC

Удалить в массиве все числа которые повторяются более двух раз

+2
Ответы (1)
  1. 29 марта, 22:44
    0
    Var n, i, a, q: integer; x: array[-30000 ... 30000] of boolean;

    begin q : = 0; write ('n=') ; readln (n) ; for i : = 1 to n do begin read (a) ; x[a] : = true; end; write ('Ваш массив без повторяющийхя элементов ') ; for i : = - 30000 to 30000 do if x[i] then begin write (i, ' ') ; inc (q) ; end; writeln; writeln ('Кол-во элементов в новом массиве=', q) ; end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Удаление повторяющихся чисел в массиве - Pascal ABC Удалить в массиве все числа которые повторяются более двух раз ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
Pascal ABC. Помогите решить задачку по программированию в Pascal. Нужно именно само действие, как найти числа которые повторяются в трочках. Сама задача звучит так: Найти все числа, каждое из которых встречается в каждой строке матрицы A (m, n)
Ответы (1)
1. Составьте программу в Pascal ABC. Даны три числа. Найти сумму двух наибольших из них. 2. Составьте программу в Pascal ABC.
Ответы (1)
Удалить в массиве второй отрицательный элемент если такой есть pascal abc
Ответы (1)