Задать вопрос
6 июля, 21:05

Pascal ABC. Помогите решить задачку по программированию в Pascal. Нужно именно само действие, как найти числа которые повторяются в трочках.

Сама задача звучит так:

Найти все числа, каждое из которых встречается в каждой строке матрицы A (m, n)

+3
Ответы (1)
  1. 6 июля, 22:50
    0
    Const

    n=2;

    m=3;

    Var

    ma:array[1 ... m, 1 ... n] of integer;

    i, j:integer;

    s:set of integer; {множество, в которое будут попадать элементы строки}

    begin

    randomize;

    s:=[];

    writeln ('Matrix:') ;

    for i:=1 to m do

    begin

    for j:=1 to n do

    begin

    ma[i, j]:=random (5) ;

    write (ma[i, j]:4) ;

    end;

    writeln;

    end;

    for i:=1 to m do

    begin

    for j:=1 to n do

    if not (ma[i, j] in s) then s:=s+[ma[i, j]]; {если элемента нет в множестве - добавляю}

    writeln (s) ; {вывод множества}

    s:=[]; {отчищаю множество для следующей строки}

    end;

    end.

    Пример работы программы:

    Matrix:

    1 1

    0 2

    0 2

    {1}

    {2,0}

    {2,0}
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Pascal ABC. Помогите решить задачку по программированию в Pascal. Нужно именно само действие, как найти числа которые повторяются в ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Понятие инкапсуляция, наследование, полиморфизм относятся к ... А) структурному программированию б) логическому программированию в) объектно-ориентированному программированию г) обозначение элементов на блок-схемах
Ответы (1)
1) Запишите внутреннее представление десятичного числа - 104 в 8-разрядной ячейке памяти компьютера Ниже запишите ответ - только само число, без пояснений 2) Запишите внутреннее представление десятичного числа 79 в 8-разрядной ячейке памяти
Ответы (1)
Для матрицы размером в n строк и m столбцов составить алгоритм и программу вычисления: 1) Сумм элементов каждой нечетной строки матрицы 2) Суммы произведений тангенсов элементов четных строк матрицы.
Ответы (1)
Напишите программу, которая обнуляет все элементы квадратной матрицы, расположенные выше главной диагонали. Входные данные В первой строке записаны через пробел размер квадратной матрицы N (количество строк равно количеству столбцов) (1 ≤ N ≤ 100).
Ответы (1)
Помогите решить задачку (Паскаль) Дана матрица B (4,4) 1) Найти произведение положительных элементов среди элеметов рассположенных выше побочной диагонали матрицы B. 2) Найти минимальный элемент во втором столбце матрицы B.
Ответы (1)