Задать вопрос
15 мая, 05:02

Дано пятизначное число. Получить число, образованное при перестановке цифр исходного числа слева направо.

+3
Ответы (1)
  1. 15 мая, 08:47
    0
    Var

    i, answer, a:integer;

    begin

    Readln (a) ; i: = 10000;

    while a > 0 do

    begin

    answer: = answer + (a mod 10) * i;

    i: = i div 10;

    a: = a div 10;

    end;

    Writeln (answer) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано пятизначное число. Получить число, образованное при перестановке цифр исходного числа слева направо. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
При выполнении какого из перечисленных ниже алгоритмов на экране появился правильный треугольник? 1 Повтори 3 [Вперёд 50 Направо 20 Направо 25] 2 Повтори 3 [Вперёд 50 Направо 100 Направо 20] 3 Повтори 6 [Вперёд 50 Направо 10 Направо 20] 4 Повтори 6
Ответы (1)
Помогите решить! 1) Дано натуральное трехзначное число N. Определить сумму и произведение его цифр. 2) Дано натуральное трехзначное число N. Найдите число, образованное перестановкой цифр исходного числа в обратном порядке.
Ответы (1)
Написать на С++. Дано двузначное число. Получить число, образованное при перестановке цифр заданного числа.
Ответы (1)
Дано четырехзначное число. Написать программу, которая находит число, образованное при перестановке первой и второй, третьей и четвертой цифр заданного числа.
Ответы (1)
Дано 4-значное число. Найти: 1) число, полученное при прочтении его цифр справа налево; 2) число, образованное перестановкой двух первых и двух последних цифр заданного числа;
Ответы (1)