Задать вопрос
14 апреля, 15:04

Дано четырехзначное число. Написать программу, которая находит число, образованное при перестановке первой и второй, третьей и четвертой цифр заданного числа.

+4
Ответы (1)
  1. 14 апреля, 18:17
    0
    program a1;

    var

    a, b, c, r:byte; l, k:word;

    begin

    read (l) ;

    a:=l mod 10;

    b:=l div 10 mod 10;

    c: = l div 100 mod 10;

    r: = l div 1000 mod 10;

    k:=c*1000+r*100+a*10+b;

    write (k) ; end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано четырехзначное число. Написать программу, которая находит число, образованное при перестановке первой и второй, третьей и четвертой ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано 4-значное число. Найти: 1) число, полученное при прочтении его цифр справа налево; 2) число, образованное перестановкой двух первых и двух последних цифр заданного числа;
Ответы (1)
Дано четырехзначное число. Найти число, образуемое при перестановке второй и третьей цифр заданного числа.
Ответы (1)
Написать на С++. Дано двузначное число. Получить число, образованное при перестановке цифр заданного числа.
Ответы (1)
Автомат получает на вход четырёхзначное десятичное число. По полученному числу строится новое десятичное число по следующим правилам. 1. Вычисляются два числа - сумма первой и второй цифр и сумма третьей и четвёртой цифр заданного числа. 2.
Ответы (1)
Помогите составить программу. Дано трехзначное число. Найти число, полученное при перестановке второй и третьей цифр заданного числа. (На паскале.)
Ответы (1)