Задать вопрос
17 апреля, 03:55

Помогите с Пасклем!

На вход программе подаются три целых числа a, b, c - длины сторон треугольника. Вывести значение площади данного треугольника. Гарантируется, что с введёнными длинами сторон треугольник существует. Можно использовать любой способ нахождения площади треугольника.

+5
Ответы (1)
  1. 17 апреля, 07:45
    0
    Var a, b, c:integer; p, s:real;

    begin

    readln (a, b, c) ;

    p: = (a+b+c) / 2;

    s:=sqrt (p * (p-a) * (p-b) * (p-c)) ;

    writeln ('s = ', s:5:2) ;

    end.

    Пример:

    3 4 5

    s = 6.00
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите с Пасклем! На вход программе подаются три целых числа a, b, c - длины сторон треугольника. Вывести значение площади данного ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите с инфой. PascalABC На вход программе подаются два целых числа m и n, по модулю не превосходящие 10^6. Если m делится на n или n делится на m, то требуется вывести 1, в противном случае - любое другое число.
Ответы (1)
Напишите программу, которая работает с двумя целыми числами, введёнными с клавиатуры. Программа выводит все чётные числа, расположенные в интервале между двумя введёнными числами.
Ответы (1)
Решите в Pascal ABC На вход программе подаются 4 целых числа, по модулю не превосходящие 10^6: m, n, k, l. Если остаток от деления m на n равен k или l, то выведите 1, в противном случае - любое другое число. Условный оператор использовать нельзя!
Ответы (1)
На вход программе подаются два целых числа m и n, по модулю не превосходящие 10 в 6 степени. Если m делится на n или n делится на m, то требуется вывести 1, в противном случае - любое другое число.
Ответы (1)
В виде программ: 1 Заполнить массив N числами (N
Ответы (1)