Задать вопрос
27 февраля, 02:18

Решите в Pascal ABC

На вход программе подаются 4 целых числа, по модулю не превосходящие 10^6: m, n, k, l. Если остаток от деления m на n равен k или l, то выведите 1, в противном случае - любое другое число.

Условный оператор использовать нельзя!

+2
Ответы (1)
  1. 27 февраля, 03:53
    0
    var m, n, k, l : longint;

    begin

    readln (m, n, k, l) ;

    writeln (((m mod n) xor k) * ((m mod n) xor l) + 1) ;

    end.

    Работает программа следующим образом:

    Если провести операцию XOR с двумя равными числами, то ответом будет 0.

    Если остаток от деления равен k или l, то одна из скобок равна 0, что при умножении даст 0. Для выполнения условия задачи добавим 1.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Решите в Pascal ABC На вход программе подаются 4 целых числа, по модулю не превосходящие 10^6: m, n, k, l. Если остаток от деления m на n ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите с инфой. PascalABC На вход программе подаются два целых числа m и n, по модулю не превосходящие 10^6. Если m делится на n или n делится на m, то требуется вывести 1, в противном случае - любое другое число.
Ответы (1)
На вход программе подаются два целых числа m и n, по модулю не превосходящие 10 в 6 степени. Если m делится на n или n делится на m, то требуется вывести 1, в противном случае - любое другое число.
Ответы (1)
Автомат получает на вход нечётное число X. По этому числу строится трёхзначное число Y по следующим правилам. 1. Первая цифра числа Y (разряд сотен) - остаток от деления X на 4. 2. Вторая цифра числа Y (разряд десятков) - остаток от деления X на 3.
Ответы (1)
1. Соотнесите названия операторов, служебных слов, функций и их написание на языке Paskal: 1. Оператор ввода данных a) Begin, End 2. Условный оператор в неполной форме b) Sqrt (X) 3. Оператор цикла с предусловием c) N div M 4.
Ответы (1)
На два входа черного ящика подаются цепочки из двоичных чисел 1 и 0. Если хотя бы на один вход подается 1, то на выходе образуется 1, в противном случае, на выходе будет 0.
Ответы (1)