Задать вопрос
17 декабря, 15:03

Написать программу, которая запрашивает строку и выводит на экран 1-й, 2-й и 5-й символы.

Паскаль abc.

+1
Ответы (2)
  1. 17 декабря, 15:22
    0
    Var s:string;

    begin

    writeln ('Введите строку:') ;

    readln (s) ;

    writeln ('s[1] = ', s[1],', s[2] = ', s[2],', s[5] = ', s[5]) ;

    end.

    Пример:

    Введите строку:

    Microsoft

    s[1] = M, s[2] = i, s[5] = o
  2. 17 декабря, 18:46
    0
    Переводим строку в массив символов. По красоте можно создать отдельно массив.

    var s : String;

    begin

    Read (s) ;

    Writeln (s. ToCharArray () [0]) ; / / число - 1 т. к. начинается все с нуля

    Writeln (s. ToCharArray () [1]) ;

    Writeln (s. ToCharArray () [4]) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу, которая запрашивает строку и выводит на экран 1-й, 2-й и 5-й символы. Паскаль abc. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
3. Написать программу, которая запрашивает ввод целого числа в переменную B и выводит это число на экран. Проверить правильность работы программы на числах 1, - 5, 256, 10455. 4.
Ответы (1)
Помогите решить две задичи Задача: Написать программу, которая а) все буквы 'а' в строке st заменяет на букву 'о' и выводит новую строку на экран б) удаляет все буквы 'а' из строки и выводит новую строку на экран
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
1. Написать программу, которая запрашивает возраст человека, а затем, если возраст меньше 14 лет выводит на экран: "У вас пока нет паспорта", если возраст больше 14 лет выводит на экран: "У вас уже есть паспорт", а если возраст равен 14 годам,
Ответы (1)
Написать программу, которая выводит на экран результаты следующих действий: 27-5= 11+21= 32/2= 2+2*2= (2+2) * 2= Написать программу, которая выводит на экран результаты следующих действий: 21-4= 21+11= 43/3= 3+3*3= (3+3) * 3=
Ответы (1)