Задать вопрос
23 марта, 15:34

Напишите программу, которая вычисляет сумму:

1) всех четных чисел в диапазоне от 1 до n;

2) всех двухзначных чисел.

+2
Ответы (1)
  1. 23 марта, 18:02
    0
    1)

    Program n1;

    var n, sum, i: integer;

    begin

    readln (n) ;

    sum:=0;

    for i:=2 to n do if i mod 2=0 then sum:=sum+i;

    write (sum) ;

    end.

    2)

    Program n2;

    var i, sum: integer;

    begin

    sum:=0;

    for i:=10 to 99 do sum:=sum+i;

    write (sum) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая вычисляет сумму: 1) всех четных чисел в диапазоне от 1 до n; 2) всех двухзначных чисел. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
2. Составить программу, которая вычисляет количество чисел кратных 3, 4 и 5 одновременно в диапазоне от 1 до 1000. 3. Составить программу, которая вычисляет факториал числа 7!
Ответы (1)
Составить программу, которая вычисляет среднеарифметическое чисел, кратных 3 в диапазоне от 1 до 200. Составить программу, которая вычисляет факториал числа 7!
Ответы (1)
напишите программу, которая вычисляет сумму: а) первых n натуральных чисел б) квадраов первых n натуральных чисел в) всех четных чисел в диапозоне от 1 до n г) всех двухзначных чисел
Ответы (1)
1. Написать программу, которая вычисляет сумму первых N четных положительных чисел. Исходные данные (N - количество чисел) вводятся с клавиатуры. Результаты работы программы записываются в файл Out. txt. 2.
Ответы (1)