Задать вопрос
22 февраля, 02:57

напишите программу, которая вычисляет сумму:

а) первых n натуральных чисел

б) квадраов первых n натуральных чисел

в) всех четных чисел в диапозоне от 1 до n

г) всех двухзначных чисел

+1
Ответы (1)
  1. 22 февраля, 05:46
    0
    Program D1LPxx10;

    uses crt;

    var

    i, n, sum4, sumkv, sum4et, sumdvy:integer;

    begin

    read (n) ;

    for i:=1 to n do

    sum4:=sum4+i;

    for i:=1 to n do

    sumkv:=sumkv+i*i;

    for i:=1 to n do

    if i mod 2=0 then

    sum4et:=sum4et+i;

    for i:=10 to 99 do

    sumdvy:=sumdvy+i;

    writeln ('summa=', sum4,' summa kvadratov=', sumkv,' summa 4etnblx=', sum4et,' summa dvyzna4nblx=', sumdvy) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «напишите программу, которая вычисляет сумму: а) первых n натуральных чисел б) квадраов первых n натуральных чисел в) всех четных чисел в ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Написать программу, которая вычисляет сумму первых N четных положительных чисел. Исходные данные (N - количество чисел) вводятся с клавиатуры. Результаты работы программы записываются в файл Out. txt. 2.
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
Напишите программу, которая вычисляет сумму: 1) всех четных чисел в диапазоне от 1 до n; 2) всех двухзначных чисел.
Ответы (1)
Напишите программу, которая вычисляет НОД двух чисел. Используйте функцию. Напишите программу, которая вычисляет НОК двух чисел. Используйте функцию.
Ответы (1)
Программирование в python 3 Напечатать массив и сумму его первых N десятков. Пример: Пользователь вводит любое число, например 56 Программа выдаёт на экран массив от 0 до 55 и ещё пять чисел: сумму первых 10, сумму первых 20, сумму первых 30, сумму
Ответы (1)