Задать вопрос
7 ноября, 17:03

Подсчитать произведение целых нечётных чисел диапазона [a, b]

+2
Ответы (1)
  1. 7 ноября, 17:58
    0
    Program Proizved;

    var i, a, b, rez : integer;

    begin

    write ('введите начало диапазона ') ;

    readln (a) ;

    write ('введите конец диапазона ') ;

    readln (b) ;

    rez:=1;

    for i:=a to b do

    if (i mod 2) 0

    then rez:=rez*i;

    i:=i+1;

    writeln ('Произведение нечетных чисел диапазона = ', rez) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Подсчитать произведение целых нечётных чисел диапазона [a, b] ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
С++ Так что бы программа просила в вести значение на русском 1. Напишите программу, которая вычисляет сумму целых чисел от а до 500 (значение a вводится с клавиатуры). 2. Найти среднее арифметическое всех целых чисел от 1 до 1000. 3.
Ответы (1)
Составьте программу в Паскале Найдите сумму чисел, кратных 2 из диапазона от 1 до 38. Найдите произведение чисел, кратных 4 из диапазона от 2 до 25.
Ответы (1)
Задача № 2. Сумма нечетных чисел Вычислить сумму всех нечетных чисел из интервала [a, b]. Например, сумма нечетных чисел из интервала [3, 9] равна 3 + 5 + 7 + 9 = 24.
Ответы (1)
1) Составить массив из 10 целых чисел, вывести его на экран и подсчитать количество элементов массива, значения которых не превышают трех 2) Составить массив из 10 целых чисел и вывести его на экран, подсчитать сумму отрицательных и положительных
Ответы (1)
Дан массив натуральных чисел заданных случайным образом из диапазона от 0 до 20 и число х из этого же диапазона. Длина массива равна N. Вставить число х после первого элемента кратного пяти
Ответы (2)