Задать вопрос
7 марта, 05:16

Составьте программу в Паскале

Найдите сумму чисел, кратных 2 из диапазона от 1 до 38.

Найдите произведение чисел, кратных 4 из диапазона от 2 до 25.

+5
Ответы (1)
  1. 7 марта, 08:47
    0
    Program n1;

    var i, s, p: longint;

    begin

    s:=0;

    p:=1;

    for i:=1 to 38 do if i mod 2=0 then s:=s+i;

    for i:=2 to 25 do if i mod 4=0 then p:=p*i;

    writeln ('сумма: ', s) ;

    writeln ('произведение: ', p) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу в Паскале Найдите сумму чисел, кратных 2 из диапазона от 1 до 38. Найдите произведение чисел, кратных 4 из диапазона от ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
С++ Так что бы программа просила в вести значение на русском 1. Напишите программу, которая вычисляет сумму целых чисел от а до 500 (значение a вводится с клавиатуры). 2. Найти среднее арифметическое всех целых чисел от 1 до 1000. 3.
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, находит сумму двузначных чисел не кратных 4. В последовательности обязательно имеется двузначное число не кратное 4.
Ответы (1)
Помогите написать программу в паскале! Написать программу в паскале: В одномерном массиве из 10 целых чисел вычислить сумму четных чисел ...
Ответы (1)
1) Вывести на экран числа кратные 16 от 31 до M (M>31) ; 2) Найти сумму 5 натуральных чисел кратных 13; 3) Найти произведение N натуральных чисел кратных 11; 4) Вывести на экран семь первых чисел кратных 7.
Ответы (1)
Помогите написать программу по Информатике! Найти произведение двузначных нечетных чисел, кратных 13. Нужно написать программу на цикле с предусловием, на Паскале.
Ответы (1)