Задать вопрос
3 августа, 14:02

Напишите программу которая определяет Верно ли что введенное число содержит по крайней мере две одинаковые цифры Возможно не стоящие рядом Паскаль ABC net

+2
Ответы (1)
  1. 3 августа, 17:49
    0
    Var

    A, B, C, D:integer;

    Begin

    Write ('Введите целое число: ') ; ReadLn (A) ;

    C : = 0;

    While (A 0) and (C < 1) do

    Begin

    C : = 0;

    B : = A mod 10;

    A : = A div 10;

    D : = A;

    while D 0 do

    begin

    if D mod 10 = B then

    C : = 1;

    D : = D div 10;

    end;

    End;

    if (C = 1) then WriteLn ('В данном числе есть одинаковые цифры')

    else WriteLn ('В данном числе нет одинаковых цифр ') ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу которая определяет Верно ли что введенное число содержит по крайней мере две одинаковые цифры Возможно не стоящие рядом ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
1) Напишите программу, которая определяет, верно ли, что введенное число состоит из одинаковых цифр (например, 222) 2) Напишите программу, которая определяет, верно ли, что введеное число содержит две одинаковые цифры, стоящие рядом (например, 221)
Ответы (1)
Напишите программу которая определяет верно ли что введенное число содержит по крайней мере две одинаковые цифры возможно не стоящие рядом как например 212
Ответы (1)
Программа паскаль Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Паскаль! Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221).
Ответы (1)