Задать вопрос
6 августа, 18:18

Напишите программу которая определяет верно ли что введенное число содержит по крайней мере две одинаковые цифры возможно не стоящие рядом как например 212

+1
Ответы (1)
  1. 6 августа, 20:17
    0
    var

    s: string;

    i, j, n: integer;

    c: char;

    flag: boolean;

    begin

    Write ('Введите произвольное число: ') ; Readln (s) ;

    flag : = false;

    n : = length (s) ;

    i : = 1;

    while (i < = n) and (not flag) do

    begin

    c : = s[i];

    j : = i + 1;

    while (j < = n) and (not flag) do

    if s[j] = c then flag : = true else j : = j + 1;

    if (not flag) then i : = i + 1

    end;

    if flag then Writeln ('Символ "', c, '" встречается больше одного раза')

    else Writeln ('Все символы уникальны')

    end.

    Тестовое решение:

    Введите произвольное число: - 1453.5462

    Символ "4" встречается больше одного раза
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу которая определяет верно ли что введенное число содержит по крайней мере две одинаковые цифры возможно не стоящие рядом ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
1) Напишите программу, которая определяет, верно ли, что введенное число состоит из одинаковых цифр (например, 222) 2) Напишите программу, которая определяет, верно ли, что введеное число содержит две одинаковые цифры, стоящие рядом (например, 221)
Ответы (1)
Напишите программу которая определяет Верно ли что введенное число содержит по крайней мере две одинаковые цифры Возможно не стоящие рядом Паскаль ABC net
Ответы (1)
Программа паскаль Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Паскаль! Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221).
Ответы (1)