Задать вопрос
24 июня, 02:10

Паскаль!

Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221).

+4
Ответы (1)
  1. 24 июня, 03:31
    0
    Var

    n, i:integer;

    s:string;

    begin

    Write ('Введите натуральное число: ') ; Read (n) ;

    Str (n, s) ;

    for i:=2 to Length (s) do

    if s[i]=s[i-1] then begin

    Writeln ('Пара одинаковых цифр-соседей ', s[i]) ;

    Exit

    end;

    Writeln ('В числе нет цифр, имеющих таких же соседей')

    end.

    Пример

    Введите натуральное число: 375422453

    Пара одинаковых цифр-соседей 2
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Паскаль! Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
1) Напишите программу, которая определяет, верно ли, что введенное число состоит из одинаковых цифр (например, 222) 2) Напишите программу, которая определяет, верно ли, что введеное число содержит две одинаковые цифры, стоящие рядом (например, 221)
Ответы (1)
Программа паскаль Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Напишите программу которая определяет Верно ли что введенное число содержит по крайней мере две одинаковые цифры Возможно не стоящие рядом Паскаль ABC net
Ответы (1)
Напишите программу которая определяет верно ли что введенное число содержит по крайней мере две одинаковые цифры возможно не стоящие рядом как например 212
Ответы (1)