Задать вопрос
14 декабря, 08:39

Написать код для паскаля!

Дракон каждый год, начиная с 10 лет отращивает по 2 новых головы. Когда ему исполняется 70 лет, он отращивает только 1 новую голову. С клавиатуры выводим возраст (n) дракона, программа выводит на экран кол-во его голов.

9 лет - 3 головы

11 лет - 7 головы

n=3+ (a*2)

70=3+ (59*2) =123

70 лет - 124 головы

+3
Ответы (1)
  1. 14 декабря, 12:15
    0
    Var a, n:integer;

    begin

    write ('a = ') ;

    readln (a) ;

    case a of

    1 ... 9 : n:=3;

    10 ... 69: n:=3+2 * (a-9) ;

    else n:=3+2 * (70-10) + (a-69) ;

    end;

    writeln ('n = ', n) ;

    end.

    Пример:

    a = 11

    n = 7
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать код для паскаля! Дракон каждый год, начиная с 10 лет отращивает по 2 новых головы. Когда ему исполняется 70 лет, он отращивает ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Паскаль помогите Дракон каждый год отращивает по три головы, но после того, как ему исполнится 100 лет - только по две. Сколько голов и глаз у дракона, которому N лет?
Ответы (1)
Программа спрашивает стороны прямоугольника, находим площадь и выводим на экран результат. Далее программа спрашивает любое число если число делиться на 5 выводит на экран сообщение число кратно 5 иначе выводит сообщение число не кратно 5 далее
Ответы (1)
Дракон имеет 3 головы: Сапфир с номером 1, Рубин с номером 2 и Изумруд с номером 3. Головы Дракона извергают пламя некоторой длины. Определить, какая из его голов извергает пламя наибольшей длины. Длина пламени определена в виде трёхзначного числа.
Ответы (1)
1. Написать программу, которая запрашивает возраст человека, а затем, если возраст меньше 14 лет выводит на экран: "У вас пока нет паспорта", если возраст больше 14 лет выводит на экран: "У вас уже есть паспорт", а если возраст равен 14 годам,
Ответы (1)
Написать программы на языке С++ 1) С клавиатуры вводится 2 числа - целое и вещественное. Программа выводит их сумму на экран.
Ответы (1)