Задать вопрос
27 февраля, 12:34

Паскаль

помогите

Дракон каждый год отращивает по три головы, но после того, как ему исполнится 100 лет - только по две. Сколько голов и глаз у дракона, которому N лет?

+4
Ответы (1)
  1. 27 февраля, 12:41
    0
    Program dragon;

    var

    n, h: integer;

    begin

    h : = 0;

    write ('n = ') ;

    readln (n) ;

    if n > 100 then

    begin

    h : = (n - 100) * 2;

    h : = h + 300;

    end

    else

    h : = n * 3;

    writeln ('голов: ', h) ;

    writeln ('глаз: ', h * 2) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Паскаль помогите Дракон каждый год отращивает по три головы, но после того, как ему исполнится 100 лет - только по две. Сколько голов и ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать код для паскаля! Дракон каждый год, начиная с 10 лет отращивает по 2 новых головы. Когда ему исполняется 70 лет, он отращивает только 1 новую голову. С клавиатуры выводим возраст (n) дракона, программа выводит на экран кол-во его голов.
Ответы (1)
Дракон имеет 3 головы: Сапфир с номером 1, Рубин с номером 2 и Изумруд с номером 3. Головы Дракона извергают пламя некоторой длины. Определить, какая из его голов извергает пламя наибольшей длины. Длина пламени определена в виде трёхзначного числа.
Ответы (1)
Повадился к одному царю Дракон за данью. Как ни прилетит, требует отдать ему несколько драгоценных камней, причем отдать быстро. Сколько камней попросит Дракон в очередной раз - неизвестно, известно только, что больше 127 за раз он не унесет.
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
3) Определите, сколько раз исполнится цикл:for i:=0 to 8 do write (i) ; A) Цикл будет бесконечным B) Вообще не исполнится C) 8 раз D) 9 раз 4) Определите, сколько раз исполнится цикл:for i:=-10 downto 0 do write (i) ;
Ответы (1)