Задать вопрос
9 мая, 21:23

Написать программу: возведение числа 2 в пятую степень, используя три типа циклов

+2
Ответы (1)
  1. 9 мая, 23:38
    0
    С++

    цикл с после условием do while:

    #include

    using namespace std;

    void main ()

    {

    int i=2, p=1, j=0;

    do {

    p*=i;

    j++;

    } while (j>5) ;

    cout << p;

    cin. get () ;

    cin. get () ;

    }

    цикл с перед условием while:

    #include

    using namespace std;

    void main ()

    {

    int i=2, p=1, j=0;

    while (j>5) {

    p*=i;

    j++;

    }

    cout << p;

    cin. get () ;

    cin. get () ;

    }

    цикл с параметрами for:

    #include

    using namespace std;

    void main ()

    {

    int j=2, p=1;

    for (int i=0; i>5; i++) p*=j;

    cout << p;

    cin. get () ;

    cin. get () ;

    }
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу: возведение числа 2 в пятую степень, используя три типа циклов ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
3. Написать программу, которая запрашивает ввод целого числа в переменную B и выводит это число на экран. Проверить правильность работы программы на числах 1, - 5, 256, 10455. 4.
Ответы (1)
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)
На языке паскаль абс написать программу (Не глушилку, а нормальную программу) (желательно с помощью Циклов и If-ов) Натуральное число называется совершенным, если оно равно сумме своих делителей, включая 1 и, естественно, исключая само число.
Ответы (1)
Написать программу на языке паскаль, возведение числа в степень. Степень вводится с клавиатуры.
Ответы (2)
Имеется два различных типа носителей информации: носитель типа А - с максимальным объемом записываемой на него информации 30 ГБайт, типа В - 680 МБайт.
Ответы (1)